顾名思义,open
是一个打开文件或目录的命令,当然也包括程序:
xxx.mp4
:open xxx.mp4
open ~
open /Applications/Safari.app/
pbcopy 和 pbpaste 是读取及写入系统剪贴板的命令,支持 Unix 管道操作,也就是说你可以 ls ~ | pbcopy
或者 pbcopy < blog.txt
。
mdfind 是 macOS 中 find 程序,由 mds 进程提供索引。
获取桌面截图。编写监控脚本的时候可能用得到。
launchd 是 macOS 中非常重要的程序,相当于 Linux 世界的 systemctl,launchctl 则提供了和 launchd 的交互。
常见用法:
launchctl list
launchctl load /path/to/your/program.plist
Launchd 脚本通常位于以下位置:
~/Library/LaunchAgents
/Library/LaunchAgents
/Library/LaunchDaemons
/System/Library/LaunchAgents
/System/Library/LaunchDaemons
强大的语音阅读程序。
阅读一段话:say "Never trust a computer you can't lift."
或者 say "你好,世界"
,当然,前提是你已经安装了对应语音的语音工具。
也可以将文本转化为音频:say -f mynovel.txt -o myaudiobook.aiff
。
相当于 Linux 下的 du?
相当于 Linux 中的 convert。
简单地缩放图片:sips -z 100 200 image.png
等比缩放:sips --resampleHeight 100 image.png
。
相当于 Linux 各发行版中的包管理工具。
安装 HomeBrew:/usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"
再安装 Cask:brew tap caskroom/cask
。
defaults write com.apple.Safari IncludeInternalDebugMenu -bool true && \
defaults write com.apple.Safari IncludeDevelopMenu -bool true && \
defaults write com.apple.Safari WebKitDeveloperExtrasEnabledPreferenceKey -bool true && \
defaults write com.apple.Safari com.apple.Safari.ContentPageGroupIdentifier.WebKit2DeveloperExtrasEnabled -bool true && \
defaults write NSGlobalDomain WebKitDeveloperExtras -bool true
sudo tmutil disablelocal # 禁止
sudo tmutil enablelocal # 启动
xcode-select --install
先列出来:xcrun simctl list
卸载无用的模拟器:xcrun simctl delete unavailable
还是 AppleScript 脚本:osascript -e 'tell application "Finder" to eject (every disk whose ejectable is true)'
建议添加到 .bashrc/.zshrc 中。
defaults write com.apple.Dock autohide-delay -float 1000 && \
killall Dock
chflags hidden /path/to/folder/
chflags unhidden /path/to/folder/
defaults write NSGlobalDomain AppleShowAllExtensions -bool true
defaults write com.apple.finder AppleShowAllFiles true
defaults write com.apple.finder AppleShowAllFiles false
defaults write com.apple.finder _FXShowPosixPathInTitle -bool true
CMD-q
退出 Finder 程序:defaults write com.apple.finder QuitMenuItem -bool true && \ killall Finder
.DS_Store
等)相关defaults write com.apple.desktopservices DSDontWriteUSBStores -bool true
echo "$(osascript -e 'tell app "Finder" to POSIX path of (insertion location as alias)')"
并没有测试过:defaults write NSGlobalDomain KeyRepeat -int 0.02
。
caffeinate -u -t 3600
sudo pmset -g
sudo pmset sleep 30
或者设置显示器休眠
sudo pmset displaysleep 15
或者禁止系统休眠
sudo pmset -setcomputersleep Never
sudo systemsetup -setrestartfreeze on
(未测试,谨慎使用)
# 启用
sudo launchctl load -w /System/Library/LaunchDaemons/ssh.plist
# 禁用
sudo launchctl unload -w /System/Library/LaunchDaemons/ssh.plist
sudo lsof -i :80
/System/Library/PrivateFrameworks/Apple80211.framework/Versions/Current/Resources/airport -I | awk '/ SSID/ {print substr($0, index($0, $2))}'
ipconfig getifaddr en0defaults read /Library/Preferences/SystemConfiguration/com.apple.airport.preferences | grep LastConnected -A 7
security find-generic-password -D "AirPort network password" -a "SSID" -gw
命令是 srm
,使用和 rm
基本一样。例如:
srm /path/to/file
$ sw_vers
ProductName: Mac OS X
ProductVersion: 10.11.6
BuildVersion: 15G31
sudo purge
显示内存统计 vm_state
defaults write com.apple.screencapture disable-shadow -bool true && \
killall SystemUIServer
并不会修改时间部分:
defaults write com.apple.screencapture name "Example name" && \
killall SystemUIServer
sudo softwareupdate -ia
# 禁止索引某个目录
mdutil -i off -d /path/to/volume
# 启用(默认行为)
mdutil -i on /path/to/volume
mdutil -E /path/to/volume
mdfind -name 'searchterm'
mdls /path/to/file
参考: